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Release Overview
Introduction

Thank you for choosing Timberline Office.

This release contains updates for 1098, 1099, W-2, and T4 tax forms for 2004 year-end 
processing.

Guide to Electronic Documentation
■ The Release Notes describe new features, known issues, and fixes. This document is 

available on your CD in the Documents folder.

■ The Technical System Reference provides detailed information about system issues. This 
document, which replaces parts of the Resource and Installation Guide, is available on 
your CD in the Documents folder.

These documents are current at the time of the release. To review support documentation 
published after the release, open the Release Update page at Timberline’s Technical 
Support Knowledgebase. See below for details.

Support

Technical Support Knowledgebase
The Knowledgebase is an online source to get answers to your Timberline application 
issues. To access the Knowledgebase, open www.timberline.com and click Client Login. 
In the next window, on the left, click Knowledgebase. Follow the instructions to log on.

After you have logged on, type a question for a specific issue, or click Release Update at 
the top of the page for a list of key support topics. 
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Contact Information
During year-end, Software Support receives a greater number of calls than normal. We 
thank you in advance for your patience during this busy time.

Please note that Software Support will be closed all day December 24 and December 31.

U.S. or Canada
Call 1-800-551-8307, fax 503-439-5333, or e-mail support@timberline.com
Support hours: Monday through Friday 6 a.m. to 5 p.m. PT (Pacific time)

Australia
Acctg/Mgmt: 1800-120-369, fax +503-439-5763, e-mail austracct@timberline.com
Estimating: 1800-120-369, fax +503-439-5333, e-mail austrest@timberline.com
Support hours: Monday through Friday 8 a.m. to 5 p.m. AET (Australian Eastern time)

Asia-Pacific
Acctg/Mgmt: +503-439-5178, fax +503-439-5763, e-mail austracct@timberline.com
Estimating: +503-439-5178, fax +503-439-5333, e-mail austrest@timberline.com
Support hours: Monday through Friday 8 a.m. to 5 p.m. AET (Australian Eastern time)

Other International Areas
Call +503-439-7155, fax +503-439-5333, or e-mail support@timberline.com
Support hours: Monday through Friday 6 a.m. to 5 p.m. PT (Pacific time)
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Install Accounting
and Management

Products
Installation Changes

The installation now prevents you from installing to a computer that uses Microsoft® 
Windows® 98 SE, Windows Me, or Windows NT®. This is in accordance with Timberline’s 
discontinuation of support for these operating systems.

Compatible CDs
The following CDs are compatible:

■ Accounting and Management Products 8.3.4 CD

■ Estimating Products 6.7.2 CD

■ Residential Management Application 8.0.0–8.3.3 CDs

IMPORTANT:  If you install both an Accounting and Management Products CD and an Estimating 
Products CD, install the Accounting and Management Products CD first. Also, please be sure to install the 
compatible versions listed above. Do not install incompatible versions such as Estimating Products 7.1.2 
and Accounting and Management Products 8.3.4.
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Supported CD Upgrade Paths

A. Before You Install
1 If you are upgrading, back up all Timberline Office program and data files.

2 Quit all programs and services for the duration of the installation. This includes programs 
that may be running in the background such as antivirus, e-mail, and backup programs.

3 Decide which installation instructions to read in this document. Most readers should start 
with “B. Install at a Server or Stand-Alone Computer” on page 4. If you have a Novell 
network, terminal server, or peer network, please start with “D. Other Installation 
Scenarios” on page 6.

B. Install at a Server or Stand-Alone Computer
1 At the server or stand-alone computer, log on with full administrative rights. Full 

administrative rights are defined as write access to the Windows registry and all folders 
on the computer (including rights to the root of all hard drives). If you are unsure whether 
you have full administrative rights, ask you network administrator for assistance. You 
can also ask your network administrator to log on with the network administrator ID 
before you start the installation.

2 Insert the Accounting and Management Products CD into the CD-ROM drive of the 
server or stand-alone computer.

3 If the Installation window does not open, click [Start] > Run. In the Run window, click 
in the Open box and type D:\Launch.exe (D:\ represents your CD-ROM drive). Click 
[OK].

4 In the Installation window, click Install prerequisite software. You must complete this 
step if the Install Timberline Office software task is dimmed. This step may require you 
to restart your server or stand-alone computer.

Upgrade From Upgrade Path

7.5.0–8.x.x Upgrade directly to 8.3.4.

7.0.0–7.4.0 Upgrade to 7.5.x or 7.6.x; then upgrade to 8.3.4.

5.4.x or earlier 1. From TS-Main, select Tools > File Doctor and apply this utility to all files before 
you upgrade your 5.4.x installation. You cannot wait until after the upgrade to 
perform this check because later versions of File Doctor are not compatible with 
5.4.x data.

2. Upgrade to 7.5.x or 7.6.x.

3. Upgrade to 8.3.4.
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NOTE:  While you are installing prerequisite software, if the Installation window does not reappear after 
the final reboot, manually install Microsoft Data Access Components 2.7 from <CD-ROM drive 
letter>:\Prerequisites\Updates\MDAC27.

NOTE:  If you receive a firewall warning message during the installation of the Pervasive database engine, 
work with your network administrator to allow the Pervasive database engine to communicate through 
your firewall software. For example, if a Microsoft Windows Firewall Security Alert window lists the 
Database Service Manager by Pervasive Software Inc., confirm with your network administrator 
that you wish to proceed; then select Unblock this program and click [OK].

5 In the Installation window, click Install Timberline Office software. Follow the 
instructions in the installation windows. This step may require you to restart your server 
or stand-alone computer.

NOTE:  If you install Payroll, the installation prompts you for a Payroll tax disk. Please ignore this message. 
Timberline will notify you when a Payroll tax update is available. After you have received notification, 
when you are ready to begin processing checks for 2005, open Payroll and select Tools > Download 
Taxes.

C. Install at a Workstation Connected to a Network
After you install to a server (“B. Install at a Server or Stand-Alone Computer” on page 4), 
follow these steps to set up your workstations.

1 At the workstation, log on with full administrative rights. Full administrative rights are 
defined as write access to the Windows registry and all folders on the computer 
(including rights to the root of all hard drives). If you are unsure whether you have full 
administrative rights, ask you network administrator for assistance. You can also ask 
your network administrator to log on with the network administrator ID before you start 
the installation.

2 Map a drive to the network shared folder on the server or peer server where you installed 
accounting and management products. This shared folder should be a parent to the folder 
where you installed Timberline Office. For example, if you installed to 
C:\TSApps\Timberline Office, you should map a drive to the shared folder TSApps.

NOTE:  The shared location mentioned above is not the same as a folder that Timberline Office installs 
called “Shared.”

3 Click [Start] > Run.

4 In the Run window, click [Browse]. In the Browse window, select Install.exe in the 
Wininst folder on the server. For example, select T:\Timberline 
Office\Accounting\Wininst\Install.exe (T:\ represents a drive mapped to the shared 
folder name in which you installed accounting and management products). Click 
[Open]; then click [OK].
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5 In the Installation window, click Install Timberline Office software. This step installs 
components necessary to run Timberline Office applications.

NOTE:  If you receive a firewall warning message during the installation of the Pervasive database engine, 
work with your network administrator to allow the Pervasive database engine to communicate through 
your firewall software. For example, if a Windows Firewall Security Alert window lists the Database 
Service Manager by Pervasive Software Inc., confirm with your network administrator that you 
wish to proceed; then select Unblock this program and click [OK].

6 Repeat steps 1–5 for each workstation.

D. Other Installation Scenarios
Read the sections below that apply to your installation scenario.

Peer Server Networks That Also Have Estimating 
Products 
Follow installation steps A, B, and C, but perform this step after the installation:

At the peer server, map a drive to the same shared folder that the workstations use. Use this 
mapped drive to access Address Book data.

Novell Server
Follow installation steps A, B, and C, with these exceptions:

■ Install to the server from a workstation. Make sure that you have a drive mapped to the 
Sys volume of the Novell server.

■ Be sure to click the Install Software for a Novell Server step before you select the 
Install Timberline Office step in the Installation window.

■ If you upgraded from an earlier Accounting and Management Products 8.x.x CD, you 
must modify some files on your server after you complete the server upgrade but before 
you install to workstations. Modify files in Timberline’s Shared folder (for example, 
T:\Timberline Office\Shared) as follows: 

Delete tcl.dll; then rename tcl.1 to tcl.dll

Delete tsactg.dll; then rename tsactg.1 to tsactg.dll

Delete tsdm.dll; then rename tsdm.1 to tsdm.dll

Terminal Server
Follow installation steps A, B, and C, with these exceptions:
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■ Click [Start] > Settings > Control Panel > Add or Remove Programs to start an 
installation to a terminal server. Starting the installation in this way makes the resulting 
software available to remote operators.

■ If your terminal server does not host Timberline Office programs and data files:

Install to the server as though it were a workstation. Perform the steps in “C. Install at 
a Workstation Connected to a Network” on page 5.

After you install Timberline Office, verify that the Pervasive.SQL database service on 
the terminal server uses an account that has the access rights of the Local System 
account plus access to all Timberline Office program and data files.

To verify your account and access rights, select Start > Programs > Administrative 
Tools > Services on the terminal server. In the Services window, right-click the 
Pervasive.SQL service and select Properties. Then, on the Log On tab, select the 
Use this account button. Work with your network administrator to enter an account 
that has the access rights of the Local System account plus access to all Timberline 
Office program and data files.

NOTE:  The Local System account, which does not typically have access to files located on another 
server, should not be selected on the Log On tab. If you use an account with insufficient access rights, you 
may receive a Pervasive status code 3119 error, which states “No authentication context is available.”

WARNING:  Do not install Timberline Office applications to a terminal server from a remote connection. 
If you attempt to install in this manner, your installation may fail or you may be unable to start Timberline 
Office applications.

E. Upgrade Data Files
If you upgraded to a new version of accounting and management products, read the 
information in this section. If this is a first-time installation of accounting and management 
products, skip to “F. After You Install” on page 9.

Prepare to Upgrade Files
The following instructions assume that you upgrade data files at your server. Timberline 
strongly recommends this method because it avoids network irregularities that can disrupt 
the upgrade.

NOTE:  If you upgrade accounting and management product data files and estimating product data files, 
be sure to upgrade accounting and management product data files first.

1 Back up your data files.

2 Make sure that no one is using Timberline Office applications.

3 Open TS-Main.
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a If you are prompted to select a data folder, but you do not see your data folder, click 
[Change Drives].

b In the Change Drives window, click [None], and select the drive that contains your 
Timberline data. Click [OK].

c Select your data folder, then click [OK].

d If you still cannot see your data folder after you change drives, click [Specify 
Folders]. In the Specify Data Folder Paths window, type the path to the folder that 
contains your data; then click [Finish]. Finally, click [OK] in the Specify Data Folder 
window.

4 If you use file locations, modify the locations to point to files on the local hard drive of 
your server.

a In TS-Main, select File > Data Folder Settings > File Locations.

b In the File Locations window, look for network paths in the Data Folder box.

c If you have network paths, write them down. You need this information for a later step.

d In the File Locations window, modify each network path to point to the appropriate 
file on the local hard drive of your server. 

e Close the File Locations window.

5 Repeat steps 3 and 4 for each data folder that you will upgrade.

Upgrade Files
1 In TS-Main, select Tools > Upgrade Files.

2 Select to upgrade either the current data folder or all data folders. 

If you select Current data folder, you upgrade files in the data folder in which you 
currently work. 

If you select All data folders, you upgrade files in all data folders that display in the 
Open Data Folder window. This may include data folders on other drives. With this 
option, the upgrade process can take a long time if you have many data folders.

3 Select files to upgrade from the Files list. Please review the table below to determine 
which files require an upgrade. 

Upgrade From Applications That Require Data Upgrades

8.3.2 and 8.3.3 General Ledger

8.3.0 and 8.3.1 Accounts Payable, General Ledger, and Payroll 
Page 8 Install Accounting and Management Products



4 Click [Start]. The Print File Selection window opens. 

5 In the File name box, type a name for the upgrade report file and click [Save]. The 
upgrade process begins in the background.

6 Review the report when the process is complete. 

The first time that you install an accounting and management products 8.x.x CD and an estimating 
products 6.5.x or later CD, be sure to upgrade your accounting and management data files before you 
upgrade your estimating data files. This ensures that the upgrade program does not duplicate contact 
information in Address Book.

Restore File Locations 
If you modified file locations, restore the previous file location entries. 

1 In TS-Main, select File > Data Folder Settings > File Locations.

2 In the File Locations window, find the file locations that you changed previously, and 
change them back to the original network path.

3 Close the File Locations window.

NOTE:  You can select to automatically upgrade files when you install the software. Files cannot be used 
by other applications while they are being upgraded.

F. After You Install

If You Have Estimating-Only Workstations
To access Address Book, Job Cost, and tax data on a server, follow the steps below for each 
Estimating-only workstation (workstations that have both estimating products and 
accounting and management products have already been configured as part of the 
accounting and management product installation).

8.2.0–8.2.2 Accounts Payable, Accounts Receivable, Address 
Book, Contracts, General Ledger, Inventory, Job 
Cost, Payroll, Project Management, Property 
Management, Purchasing, and Service 
Management

7.5.x or 7.6.x Upgrade all accounting and management 
product data files.

Upgrade From Applications That Require Data Upgrades
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1 Map a drive to the network shared location on the server or peer server where you 
installed Timberline accounting and management products. This shared folder should be 
a parent to the folder where you installed Timberline Office. For example, if you installed 
to C:\TSApps\Timberline Office, you should map a drive to the shared folder TSApps. 
The mapped drive would appear as T:\Timberline Office.

NOTE:  The shared location mentioned above is not the same as a folder that Timberline Office installs 
called “Shared.”

2 Click [Start] > Run.

3 In the Run window, click [Browse]. Select the path to Wininst\Install.exe on the server 
(for example, T:\Timberline Office\Accounting\Wininst\Install.exe, if T:\ is the drive 
that you mapped in step 1). Click [Open]; then click [OK].

4 In the Installation window, click Install Timberline Office software. If this step is not 
available, click Install prerequisite software; then, after prerequisite software installs, 
click Install Timberline Office Software. These steps may require you to reboot 
multiple times.

5 Repeat steps 1–4 for each Estimating-only workstation.

Final Steps
1 Restart all programs and services that you shut down for the installation.

2 If you use Inventory, Purchasing, or Service Management custom Crystal reports, please 
see Crystal Reporting for information about upgrading these reports. This document is 
available on the Timberline Office Accounting and Management Products CD at 
\Documents\Crystal.pdf.

3 Timberline provides numerous supporting documents in Adobe® Acrobat (.pdf) format. 
If you do not already have Adobe Acrobat or Acrobat Reader, you should install Acrobat 
Reader by starting the program D:\AdditionalInstalls\Adobe\ar500enu.exe on your 
Accounting and Management Products CD (D:\ represents your CD-ROM drive).
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System
Requirements

The hardware and software requirements below are a guideline. For more detailed 
information, please contact your Timberline business partner or sales representative.

Supported Operating Systems
■ Windows Server 2003 Standard Edition

■ Windows 2000 Advanced Server

■ Windows 2000 Server

■ Windows 2000 Professional

■ Windows XP Professional

■ NetWare® 4.2 with Service Pack 9

■ NetWare 5.1

■ Palm OS® 4.0, 4.1, 5.2-5.2.1 (Mobile Estimating, Mobile Purchasing, and Mobile 
Inventory) and Palm OS 3.1-3.53 (Mobile Purchasing and Mobile Inventory)

Processor
■ 500 MHz except for NetWare servers, which require 300 MHz.

RAM
■ 512 MB RAM for Windows Server 2003 and Windows 2000 Server
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■ 256 MB RAM for Windows 2000 Professional, Windows XP Professional, and NetWare

■ 8 MB RAM for Mobile Purchasing and Mobile Inventory, 2 MB for Mobile Estimating 
(handheld device RAM)

Hard Disk Space
■ Accounting and management products on a server or stand-alone computer: 400 MB 

available disk space plus 30 MB per accounting and management application

■ Accounting and management products on a workstation: 295 MB available disk space 
(this assumes that a server hosts accounting and management data)

Other Requirements
■ CD-ROM drive

■ Crystal Reports® Professional or Timberline's Crystal Reports (Required to modify or 
create Crystal Reports designs)

■ High-quality network interface card

■ Sound card

■ SVGA monitor (800 x 600 pixels, 1024 x 768 pixels recommended for Project 
Management and Database Editor)

■ Microsoft Internet Explorer 6.0 (Service Pack 1)

■ Microsoft Outlook® (required to use e-mail features)

■ Printer

■ WinFax Pro 10.0, 10.01, or 10.03 (required to send faxes in applications with this 
feature)

Supported Protocols
■ TCP/IP Transmission Control Protocol/Internet Protocol. Microsoft servers default to 

this protocol.

■ IPX/SPX (Internetwork Packet Exchange/Sequenced Packet Exchange. Novell protocol 
that is the standard in NetWare 4.x.)

■ RDP 5 Remote Display Protocol. Microsoft remote protocol, which is used in its remote 
connection applications.

■ ICA Independent Computing Architecture. Citrix remote protocol, which is used in its 
remote connection application.
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