Home

» User Account Control (UAC) > About User Account Control

User Account Control (UAC)

Learn About...

What is User Account Control (UAC)?

User Account Control (UAC)—Definition

How does UAC work?

Understanding Windows Security

Is my software compliant?

Accounting Applications Compliance

Estimating Applications Compliance

UAC Help Version

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.

More resources

For additional online resources for Sage products, visit the Sage Customer Portal. Use the portal to access the knowledgebase, chat online with customer support, or enter a customer support ticket.

For additional training on Sage products, visit Sage University.


Accounting Applications Compliance

To ensure Sage 300 Construction and Real Estate programs comply with the UAC security scheme, many Sage 300 Construction and Real Estate files have been moved from the Program Files folder to a shared location. The critical program files are being installed in the normal installation location while data and other files are being installed to a shared location. For new installations of Sage 300 Construction and Real Estate on Windows Vista or Windows Server 2008, these files are being installed in the [Drive]:\ProgramData\Sage\Timberline Office folder. For new installations on Windows XP, Windows Server 2003, or earlier systems, these files are being installed in the [Drive]:\Documents and Settings\All Users\Application Data\Sage\Timberline Office folder.

Note: User-accessed Sage 300 Construction and Real Estate files will no longer be kept or created in the Program Files folder. This ensures standard users have the appropriate read/write permissions to operate Sage 300 Construction and Real Estate programs.

Unlike with Estimating programs, if you are upgrading from a previous version of Sage 300 Construction and Real Estate, your program data is not copied automatically to the new shared location. If you are upgrading, you do not need to move folders to comply with UAC requirements unless you also install the Windows Vista® or Windows Server 2008 operating system and your data is not in a shared location.

If you install Windows Vista or Windows Server 2008 and your data is not already shared, you will need to share the data folders or move them and update their new shared location using File Tools. The default shared location for data files and reports in Windows Vista and Windows Server 2008 is X:\ProgramData\Sage\Timberline Office.

Note: Some of data and report folders may be hidden in their new locations. To view them, open Windows Explorer, select Tools > Folder Options, and select the View hidden files and folders check box on the View tab.

Storing data folders or reports in a non-compliant location is not allowed. Your Sage 300 Construction and Real Estate program will return an error message if you attempt to open or save a folder or file in a non-compliant location.

Understanding Windows Security

UAC Compliance - Definition

User Account Control (UAC) - Definition

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.

More resources

For additional online resources for Sage products, visit the Sage Customer Portal. Use the portal to access the knowledgebase, chat online with customer support, or enter a customer support ticket.


Estimating Applications Compliance

To ensure Sage 300 Construction and Real Estate complies with the UAC security scheme, all program data folders and report files have been moved from the Program Files folder to a shared location. The default for this shared location is the X:\Users\Public\Estimating folder in Windows Vista or the X:\Documents and Settings\All Users\Estimating folder in Windows XP. User-accessed Sage 300 Construction and Real Estate files will no longer be kept or created in the Program Files folder. This ensures standard users have the appropriate read/write permissions to operate Sage 300 Construction and Real Estate programs.

If you are upgrading from a previous version of Sage 300 Construction and Real Estate , and your Estimating data currently resides in the Program Files folder, your Estimating data files are automatically copied for you to the new shared location. You should verify your program operates correctly and you have access to your data. After making this verification, remove the original data files from the Program Files folder. If you are operating in a workstation/server environment, ensure you also map your workstations to the new shared folder on the server.

Note: Some data and report folders may be hidden in their new locations. To view them, open Windows Explorer, select Tools > Folder Options, and select the View hidden files and folders check box on the View tab.

Storing Sage 300 Construction and Real Estate data folders or reports in a non-compliant location is not allowed. This is to prevent virtualization of your data. Your Sage 300 Construction and Real Estate program will return an error message if you attempt to open or save a folder or file in a non-compliant location.

Understanding Windows Security

UAC Compliance - Definition

User Account Control (UAC) - Definition

Virtualization - Definition

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.

More resources


Elevating Permissions

Certain tasks in Windows Vista require Administrator-level permissions to complete. By default, you are assigned standard user-level permissions when performing most tasks in Windows. However, if you are logged in as an Administrator, you have the ability to elevate your permissions level at any time to perform tasks requiring this level of control.

To elevate your permissions level

  1. Right-click on the item you are trying to open or task you are trying to perform.
  2. Select Run As Administrator.
  3. In the User Account Control window, sign in with your logon name and password.
  4. Click [Continue].

Understanding Windows Security

(missing or bad snippet)

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


File Path Requirements

Files saved in Windows® must meet specific file path and file name criteria:

  • File names and file paths must use standard characters only. Standard characters include uppercase letters (A-Z), lowercase letters (a-z), numbers (0-9), hyphens (-), or a combination thereof.
  • The character length of the file path\file name combination cannot exceed 260 characters.

Some Sage 300 Construction and Real Estate database files may be close to the maximum character limit because of their file paths. If a file path\file name combination exceeds the limit, try renaming the file or saving the file to another UAC-compliant location.

Note: Commercial Construction Knowledgebase (CK) database files are saved to a default file path that results in file path\file name combinations which are close to the maximum character limit ([Drive]:\Documents and Settings\All Users\Estimating for Windows XP, Windows Server 2003, and earlier systems, [Drive]:\Users\Public\Estimating for Windows Vista and Windows Server 2008). Attempting to move the CK database may result in operating errors. Therefore, ensure you observe the maximum character limit and choose file names carefully.

UAC Compliance—-Definition

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Understanding Windows Security

With the release of the Vista platform, Windows security is now based on the User Account Control (UAC) scheme. The goal of this security scheme is to provide users with only the required level of permissions to perform daily tasks, thereby limiting system exposure in the event of a malicious attack. For example, UAC divides users into two groups: standard users and administrators. By default, all users are assigned standard user-level permissions. Rather than provide standard users with full system control, Windows now gives standard users the ability to access only the folders to which they have read/write permissions. Administrators must assign read/write permissions for each folder a standard user is expected to read or write to. Administrators must also approve any programs a standard user attempts to install.

Administrators are limited to the standard user-level permissions. However, administrators have the ability to elevate their own permissions as required to perform tasks such as assigning permissions, installing software, or making system modifications.

To further protect the system, Windows has the ability to isolate your data should you attempt to read or write to a file without having read/write permissions to that file/folder. Windows virtualizes the compromised file, making a copy of it and associating it with your user profile. Any file modifications you make are limited strictly to the copied file, leaving the original file unchanged.

Accounting Applications Compliance

Estimating Applications Compliance

UAC Compliance—Definition

User Account Control (UAC)—Definition

Virtualization—Definition

Elevating Permissions

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Administrators—Definition

Home

Although they operate with standard user-level permissions, administrators have the ability to elevate their own permissions level as required to perform administrative tasks. Included among these tasks is assigning other users read/write permissions to a folder/file and approving programs other users attempt to install.

Understanding Windows Security

Standard Users—Definition

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Standard Users—Definition

Standard users are users or operators who have limited system access. Generally, standard users can access only the folders to which they are granted read/write access. Standard users must also have administrator approval prior to installing any program.

Understanding Windows Security

Administrators—Definition

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


UAC Compliance—Definition

You must have read/write permissions to a folder in order to save and open program files in Windows®. When permissions are set on a folder, and you have read/write permissions to that folder, the folder is User Account Control (UAC) compliant.

Understanding Windows Security

User Account Control (UAC)—Definition

Virtualization—Definition

Accounting Applications Compliance

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


User Account Control (UAC)—Definition

User Account Control (UAC) is a Windows security scheme dividing users into one of two groups: standard users and administrators. By default, all users operate as standard users. Standard users must have read/write permissions assigned specifically to gain write access to folders and files, and must gain administrator approval to install programs or perform system modifications. However, those users belonging to the administrators group can temporarily elevate their own permissions level to access all folders and perform administrative tasks such as assign permissions, assign privileges, and perform system modifications.

Understanding Windows Security

UAC Compliance—Definition

Virtualization—Definition

Accounting Applications Compliance

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Virtualization—Definition

Virtualization is the creation of a private user copy of a file or files for the purpose of protecting the integrity of a program from unauthorized users. If you attempt to read or write to a file to which you do not have read/write permissions, Windows creates a private copy of the file in your user profile, leaving the file you attempted to access untouched.

Understanding Windows Security

UAC Compliance—Definition

User Account Control (UAC)—Definition

Accounting Applications Compliance

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Company List Error

Home

This message appears when you select a company in the Company Selector having an associated data folder that is not stored in a compliant location. Beginning with the 9.5 release, all data folders must be stored in a location to which you have read/write permissions. You cannot open data folders from a location to which you do not have read/write permissions.

When this message is encountered, it indicates you are trying to open a data folder to which you do not have read/write permissions. The company you are selecting will be added to the company list but you will not be able to open the company's data folder. To open the associated data folder, you must contact the system administrator to have read/write permissions granted to you before selecting this company.

Understanding Windows Security

Accounting Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Company Location Error

Home

This message appears when you attempt to create a company and save its associated data folder to a non-compliant location. All data folders must be stored in a location to which you have read/write permissions. You cannot open data folders from a location to which you do not have read/write permissions.

When this message is encountered, contact the system administrator to have read/write permissions granted to you before saving the associated data folder to this location or else save the data folder to another location to which you have these permissions.

Understanding Windows Security

Accounting Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Data Folder Access Error

This message appears when you attempt to open an associated data folder from a non-compliant location. Beginning with the 9.5 release, all data folders must be stored in a location to which you have read/write permissions. You cannot open data folders from a location to which you do not have read/write permissions.

When this message is encountered, it indicates you are trying to open a data folder to which you do not have read/write permissions. To open the file from this location, you must contact the system administrator to have read/write permissions granted to you.

Understanding Windows Security

Accounting Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


File Location Error (Accounting)

File Location Error

This message appears when you attempt to save a file to a non-compliant location. Beginning with the 9.5 release, all program files must be stored in a location to which you have read/write permissions. You cannot store files to a location to which you do not have read/write permissions.

When this message is encountered, it indicates you are trying to save a file in a folder to which you do not have read/write permissions. To save the file to this location, you must contact the system administrator to have read/write permissions granted to you or you must save the file to another location.

Understanding Windows Security

Accounting Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Dictionary Files Error

Dictionary files define the metadata or composition of a Pervasive database header or record. For example, they indicate the names of records, the number of columns, and whether the column is text or numeric. The Pervasive database requires this information to operate correctly. All Estimating dictionary files end with the file extension *.dct and can be found in X:\Documents and Settings\All Users\Sage\Timberline Office\9.5\Estimating\Dictionaries.

If you receive a dictionary files error, you may be missing one or more dictionary files that are normally installed during the installation process. To resolve this issue, contact your system administrator and run the Estimating installation again.

Pervasive Configuration Error

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


File Access Error

This message appears when you attempt to open a file or data folder from a non-compliant location. Beginning with the 9.5 release, all Estimating files must be stored in a shared location to which you have read/write permissions. You cannot open files from a location to which you do not have read/write permissions. This is to prevent virtualization, a mechanism by which Windows makes a copy of the file you are trying to open and associates it with your user profile. When virtualization occurs, all data you enter is saved to the copy and is therefore unavailable to others. Although virtualization only occurs in the Windows Vista operating system, Estimating requires your files to be moved to a shared location even if you are using another operating system to prepare your data for an eventual, possible move to Windows Vista.

When this message is encountered, it indicates you are trying to open a file or data folder to which you do not have read/write permissions. To open the file from this location, you must contact the system administrator to have read/write permissions granted to you.

Understanding Windows Security

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


File Location Error (Estimating)

File Location Error

This message appears when you attempt to save a file to or open it from a non-compliant location. Beginning with the 9.5 release, all program files must be stored in a shared location to which you have read/write permissions. You cannot store files to a location to which you do not have read/write permissions. This is to prevent virtualization, a mechanism by which Windows makes a copy of the data folder you are trying to save and associates it with your user profile. When virtualization occurs, all data you enter is saved to the copy and is therefore unavailable to others. Although virtualization only occurs in the Windows Vista operating system, Estimating requires your files to be moved to a shared location even if you are using another operating system to prepare your data for an eventual, possible move to Windows Vista.

When this message is encountered, it indicates you are trying to save a file in a folder to which you do not have read/write permissions. To save the file to this location, you must contact the system administrator to have read/write permissions granted to you or you must save the file to another location.

Understanding Windows Security

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


File Save Error

This message appears when you attempt to open a file from or save a file to a non-compliant location. Beginning with the 9.5 release, all program files must be stored in a shared location to which you have read/write permissions. You cannot store files to a location to which you do not have read/write permissions. This is to prevent virtualization, a mechanism by which Windows makes a copy of the data folder you are trying to access/save and associates it with your user profile. When virtualization occurs, all data you enter is saved to the copy and is therefore unavailable to others. Although virtualization only occurs in the Windows Vista operating system, Estimating requires your files to be moved to a shared location even if you are using another operating system to prepare your data for an eventual, possible move to Windows Vista.

When this message is encountered, it indicates you are trying to open a file or save a file or in a folder to which you do not have read/write permissions. To save the file to this location, you must contact the system administrator to have read/write permissions granted to you or you must save the file to another location.

Understanding Windows Security

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Pervasive Configuration Error

The Pervasive database is used to store program data. The database is configured at the time of installation. If you receive this error message, one or more of the Pervasive settings are incorrect. Run the Sage System Verifier to determine which settings are wrong and correct any issues that are found.

Dictionary Files Error

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Reserved File Access Error

For Windows® XP® and older operating systems, you receive this error if you attempt to perform file operations (open or save a file) to or from a reserved location. Reserved locations are folders such as the Program Files folder that are set aside for Microsoft files. Although you may already have read/write permissions, in following Microsoft UAC guidelines, Sage Estimating programs no longer allow you to store files in these folders.

To open or save a file, move all of your program data using File Tools to a shared location such as the Documents and Settings folder if you have not already done so. Open or save the file to/from the shared folder.

Estimating Applications Compliance

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


Estimating UAC Configuration and Setup Window

This window provides details during the Estimating install. As part of the UAC process, Estimating installer will copy all Estimating folders from the Program Files folder—or any other non-compliant folder— into a shared location to meet UAC compliance requirements. The Moved Databases box lists the individual databases that are moved, their original locations (normally in the Program Files folder), and their new shared locations. After the upgrade is finished, verify your program operates correctly and you have access to your data then remove the original databases and data files from the Program Files folder.

Note: Some of these folders are hidden in their new location. To view them, open Windows Explorer, select Tools > Folder Options, and select the View hidden files and folders check box on the View tab.

The upgrade process also performs these tasks:

  • Sets up all default shared folder paths.
  • Scans the Program Files folder for all databases and copies them to a shared location.
  • Copies application data files to a shared folder.

Click [Click to Begin] to begin the upgrade process.

Note: Select the Overwrite files found in the destination folder(s) check box to overwrite any existing database files already in the shared location.

You can view the status of the upgrade process in the Current Status box. You can also print out a report of the upgrade process by clicking [View Report].

Understanding Windows Security

User Account Control (UAC)—Definition

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.


UAC Help

User Account Control (UAC) Help

User Account Control (UAC) version 12.1.0

May 7, 2012

Help us improve our user assistance.

Was this topic helpful to you?

Sending...
Your comments have been sent. Thank you!
Comment not sent -- Please check your internet connection and try again.
A server error has occurred -- Please try again later.